"User not present in this conversation"

Talk about anything about MSN Messenger for mIRC or leave some comments.
Asherett
Posts: 8
Joined: Wed Oct 07, 2009 14:54 pm

"User not present in this conversation"

Post by Asherett » Wed Oct 07, 2009 15:13 pm

Using MSN for mIRC 4.00, windows 7 (build 7600.16385), mIRC 6.35

Having 2 main problems. When communicating with users that have the very newest Messenger version (version "2009", build 14 and up), they keep "dropping out" of conversations somehow. They can even send messages to me, and I'm unable to respond, getting a "User is not present in this conversation" error message. This is fixed by closing the window and opening a new window with the user, but rather annoying.

Problem 2: the client doesn't send special characters (æ, ø, å in my case, I'm Norwegian) correctly (or the live messenger 2009 can't read what I send properly). Such characters show up as a kind of black diamond with question mark symbol <?>. I guess this might be fixable in my mIRC somehow?

Asherett
Posts: 8
Joined: Wed Oct 07, 2009 14:54 pm

Re: "User not present in this conversation"

Post by Asherett » Fri Oct 09, 2009 19:22 pm

Probably more people out there having these problems. Any other info I can provide or other things I can do to help out debug?

andyc
MSN for mIRC Creator
Posts: 245
Joined: Sun Dec 01, 2002 21:26 pm

Re: "User not present in this conversation"

Post by andyc » Sat Oct 10, 2009 21:03 pm

Thanks for reporting it - I'll check it out now.

The foreign characters used to be a big problem with the script. I did fix it though, but it appears that it may have broken again! I'll take a look at that now too. :)

andyc
MSN for mIRC Creator
Posts: 245
Joined: Sun Dec 01, 2002 21:26 pm

Re: "User not present in this conversation"

Post by andyc » Sat Oct 10, 2009 21:24 pm

It looks like when a "foreign" character is sent, such as the ones you have said, this causes MSN to disconnect the client.

Can you confirm that if you have a conversation without using any of the characters you mention, it doesn't disconnect you?

andyc
MSN for mIRC Creator
Posts: 245
Joined: Sun Dec 01, 2002 21:26 pm

Re: "User not present in this conversation"

Post by andyc » Sat Oct 10, 2009 21:46 pm

Think I've fixed it. I'd be really grateful if you could test it for me. Could you press Alt-R in mIRC and click the 'Remote' tab. Then click View > msn.mrc.

Then hit Ctrl-G and go to line 653, replace:

Code: Select all

sockwrite -n chat. $+ $right($active,$calc($len($active)-1)) MSG %msn. [ $+ [ $right($active,$calc($len($active)-1)) ] ] N $calc($len(%msn.texttosend) + 132)
with:

Code: Select all

sockwrite -n chat. $+ $right($active,$calc($len($active)-1)) MSG %msn. [ $+ [ $right($active,$calc($len($active)-1)) ] ] N $calc($len($utfencode(%msn.texttosend)) + 132)
Also, press Ctrl-G and go to line 658, replace:

Code: Select all

sockwrite chat. $+ $right($active,$calc($len($active)-1)) %msn.texttosend
with:

Code: Select all

sockwrite chat. $+ $right($active,$calc($len($active)-1)) $utfencode(%msn.texttosend)
If you have any problems, let me know. :)

Asherett
Posts: 8
Joined: Wed Oct 07, 2009 14:54 pm

Re: "User not present in this conversation"

Post by Asherett » Sun Oct 11, 2009 14:17 pm

Ha, glorious. This seems to have fixed "both problems", seems they were actually one. And yes, I were not disconnected from conversations with users where I wrote only english - I thought that had to do with their client tho. I'll report back if I encounter anything more.

Do you have a paypal donation account or something like that? Really love your script and wouldn't mind giving you a small something for the work :)

Asherett
Posts: 8
Joined: Wed Oct 07, 2009 14:54 pm

Re: "User not present in this conversation"

Post by Asherett » Sun Oct 11, 2009 17:23 pm

Bah, unfortunately the "disconnect" thing seems to persist still. It doesn't seem to be dependent on me typing anything. I can be messaged, respond, then the other part types a few messages, and I'll suddenly find myself unable to reply. It only seems to happen with one of the two people I regularily chat with though... It's not dependent on foreign characters as such though, I can be DCed just be receiving a http link. Actually, could that be a cause?

andyc
MSN for mIRC Creator
Posts: 245
Joined: Sun Dec 01, 2002 21:26 pm

Re: "User not present in this conversation"

Post by andyc » Sun Oct 11, 2009 18:08 pm

Hmmm - may be.

I'm away from home today so can't look unfortunately, but if you can establish if there's any pattern to what makes it disconnect that'd be great!

Asherett
Posts: 8
Joined: Wed Oct 07, 2009 14:54 pm

Re: "User not present in this conversation"

Post by Asherett » Tue Oct 13, 2009 9:58 am

This is proving hard. As far as I can see, it seems to DC (I start getting "User not present" messages) if I don't answer (send any message) in about 20-30 minutes. Note that the other guy can still send messages to me. I'm unable to recreate anything that makes the DC happen immediately, but it seems to always be DCed after a while.

andyc
MSN for mIRC Creator
Posts: 245
Joined: Sun Dec 01, 2002 21:26 pm

Re: "User not present in this conversation"

Post by andyc » Tue Oct 13, 2009 11:39 am

Cool thanks - I'll look into it.

andyc
MSN for mIRC Creator
Posts: 245
Joined: Sun Dec 01, 2002 21:26 pm

Re: "User not present in this conversation"

Post by andyc » Wed Oct 14, 2009 21:31 pm

Not managed to reproduce it unfortunately. Even when a window is left for an hour.

Are you talking to several people at the same time? That could be something to do with it.

Asherett
Posts: 8
Joined: Wed Oct 07, 2009 14:54 pm

Re: "User not present in this conversation"

Post by Asherett » Thu Oct 15, 2009 8:41 am

No, can just have one window open, still happens, can happen in down to 10-15 minutes. I've noticed that the same fellow tends to show up as offline for me when he first connects. He says he has to change his status to for example Away and then back again to online, then he will appear to log on for me. Kinda annoying, as this makes him able to send me messages while appearing to be offline, and with me unable to respond in any way. My usual solution to the "User not present" problem is to simply close the window and open a new conversation with the guy from the list, but when he shows as offline I can't do that... :)

andyc
MSN for mIRC Creator
Posts: 245
Joined: Sun Dec 01, 2002 21:26 pm

Re: "User not present in this conversation"

Post by andyc » Thu Oct 15, 2009 9:18 am

Yeah that's a bug I've just fixed. MSN have changed the way they alert when a user comes online - not sure if they were trying to break third party clients or not!

I'll have a look a bit deeper into the problem today and will hopefully release a version today or tomorrow that fixes the fact that you're not alerted to a new user online as well as the foreign character bug.

Asherett
Posts: 8
Joined: Wed Oct 07, 2009 14:54 pm

Re: "User not present in this conversation"

Post by Asherett » Sun Oct 18, 2009 17:55 pm

Just noting that I still have the disconnecting issue in 4.01.

andyc
MSN for mIRC Creator
Posts: 245
Joined: Sun Dec 01, 2002 21:26 pm

Re: "User not present in this conversation"

Post by andyc » Sun Oct 18, 2009 17:59 pm

Bah that's annoying!

I'll try a bit harder to reproduce it! Many thanks for letting me know. :)

Post Reply